Logout URL does not redirect to IDP logout consistently in New UX Clarity SaaS & Federated SSO
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Logout URL does not redirect to IDP logout consistently in New UX Clarity SaaS & Federated SSO

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Article ID: 200063

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Updated On:

Products

Clarity PPM SaaS

Issue/Introduction

After enabling Federated SSO in our Clarity SaaS environment,  when we click the logout button, it is successfully re-directing to our IdP logout page, https://company.com/idp/logout.test When we go back to the homepage link, https://cppm####-dev.clarityppm.saas.broadcom.com/, it is not re-directing to our SSO login page. It is again re-directing back to our logout page. Why is this happening?
 
SUMMARY: Clarity Login page is displayed sometimes. Users have had an issue where they get directed to the Clarity login page instead of the IDP Login page to login. All users are using the SP initiated link . The issue can be resolved by clearing browser data but a few hours later the same issue occurs. It’s not ideal to have to keep doing this to login 
 
STEPS TO REPRODUCE: 
1. Login to Clarity modern ux using SSO in GCP SaaS System
2. Set the Inactivity time out to 60 minutes 
3. Leave the clarity idle for 60 minutes 
 
Expected Results: Once the system is idle for 60 minutes it should log out and send back to logout page 
 
Actual Results: Clarity Modern UX login page shows in the screen post inactivity of 60 minutes 
Workaround: Hit the Clarity URL again to initiate the SSO session again. 

Environment

Release : 15.8.1

Component : CA PPM SAAS APPLICATION

Cause

This is a defect DE57954  

Resolution

DE57954  fixed in 15.9