Spectrum WebApp not loading with message Request processing failed. Please refer the tomcat log for more details
search cancel

Spectrum WebApp not loading with message Request processing failed. Please refer the tomcat log for more details

book

Article ID: 200041

calendar_today

Updated On:

Products

CA Spectrum CA eHealth

Issue/Introduction

Spectrum WebApp not loading and WebTomcat is running.

Trying to connect to the Webapp configuration page using the Webapp connector port returns HTTP Status 404 - Not Found:

 

 

Environment

Release : 10.4.x

Component : Spectrum Core / SpectroSERVER

Cause

An incomplete Webswing installation is preventing the WebApp from loading in the browser. 

NOTE:    On RHEL package xorg-x11-server-Xvfb-1.10.4-6.el6.x86_64 is a pre-requisite for using WebApp.   If this package does not exist the spectrum folder will not be created from the spectrum.war file.

 

Resolution

If the SPECROOT/webtomcat/webswing folder DOES NOT exist:

1.  You can copy it from another instance of OneClick running the same version or uninstall\resintall OneClick.  You can also extract webswing.zip if this exists which will create the SPECROOT/webtomcat/webswing folder.

2.  Then copy the SPECROOT/webtomcat/webswing/spectrum.war to the webtomcat/webapps folder.

3. Start WebTomcat ($SPECROOT/webtomcat/bin/startWebTomcat.sh)

4. The spectrum.war file will create a new spectrum folder and fully populate it.

If the SPECROOT/webtomcat/webswing folder exists:

1.  cd $SPECROOT/webtomcat/webapps

2.  Rename the spectrum folder

3.  $SPECROOT/webtomcat/bin/startWebTomcat.sh

The spectrum.war file will create a new spectrum folder and fully populate it.


Additional Information

OneClick WebApp User Guide

Attachments