Warning message "Failed to restore association..." while running NewMM.pl script
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Warning message "Failed to restore association..." while running NewMM.pl script

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Article ID: 199899

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Updated On:

Products

CA Spectrum CA eHealth

Issue/Introduction

While running NewMM.pl post-installation script to change the model type these warning messages are returned:

Warning
Error Code = 12
Failed to restore association. Left Model handle : 80b1bc, Right Model handle : 804d5a for relation 4a40000
Already exist.

The conversion seems to work fine anyway. 

Environment

Release : All releases

Component : Spectrum Core / SpectroSERVER

Cause

The conversion and association has already been done for that device. 

Resolution

This Warning message could be seen if:

The device is already part of a (custom) Family,

The association is already created by the conversion done running the script a second time for the same device.

When the conversion happens Spectrum identifies the device supports a given Family, and places the device there.
As part of the conversion, it restore the existing associations. If the device is already part of a Family, the creation of an association is no longer needed.
In this case, NewMM.pl script returns the Warning message informing that this association cannot be created.
In such cases, this Warning can be ignored.