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Unable to connect to Automic after server restart

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Article ID: 199660

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Updated On:

Products

CA Automic Workload Automation - Automation Engine CA Automic Workload Automation - Automation Engine

Issue/Introduction

Error: U04006523 Could not establish a connection to AE system 'Automic' (IP address: 'XXXXXXXXXX', Port: '2219') in a timely fashion.
Please check if CP/WP-servers are running, the connection data in uc4config.xml are set correctly and the database service is available.

Cause

The database user password had changed

Environment

Release : 12.2

Component : AUTOMATION ENGINE

Resolution

20200916/230104.577 - U00003591 UCUDB - DB error info: OPC: 'SQLDriverConnect' Return code: 'ERROR'
20200916/230104.577 - U00003592 UCUDB - Status: '28000' Native error: '18456' Msg: 'Login failed for user 'uc4'.'
20200916/230104.577 - U00003590 UCUDB - DB error: 'SQLDriverConnect', 'ERROR ', '28000', 'Login failed for user 'uc4'.'

We were able to telnet to the database port.

Was able to login using SQL Server Management Studio


Took a backup of ucsrv.ini and updated the password in cleartext. It worked fine.
Then encrypted the password using UCYBCRYP.EXE  and updated encrypted password in the ucsrv.ini.

SQLDRIVERCONNECT=ODBCVAR=NNNNNNRN,DSN=UC4;UID=uc4;PWD=--1037B2E22BF022EBE2

The CP and WP services started fine

Additional Information

For more details on encoding passwords please refer to the following documentation

Encoding Passwords