Legacy Api portal 502 Proxy Error after logging in
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Legacy Api portal 502 Proxy Error after logging in

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Article ID: 199359

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Updated On:

Products

CA API Developer Portal

Issue/Introduction

On the Legacy  api portal  we are getting  502 Proxy error after logging in , this only  occurs on the secondary portal server after configuring the failover .

https://techdocs.broadcom.com/us/en/ca-enterprise-software/layer7-api-management/api-portal-legacy/3-5/set-up-the-api-portal/configure-the-api-portal-replication/replication-configuration-scenarios.html

Environment

Release : 3.5

Component : API PORTAL

Cause

The problem occurs after logging on to the secondary portal for the second time the first time seems to work or after doing some actions .

Also the catalina.out is filled with the following error when the error occurs

09/01 03:48:05.414 ERROR (ReplicationThread:) - Cannot get a connection, pool error Timeout waiting for idle object
09/01 03:48:05.414 ERROR (ReplicationThread:) - [general] -- Failed to persist change for replication

Resolution


To resolve this please do the following on the secondary portal server. 

open the jforum-custom.conf file and edit the following line

database.connection.pool.max=10

change it to

database.connection.pool.max=25

Restart the secondary portal