ALERT: Some images may not load properly within the Knowledge Base Article. If you see a broken image, please right-click and select 'Open image in a new tab'. We apologize for this inconvenience.

Do CA Gen 8.6 applications work with COBOL V4R2

book

Article ID: 199311

calendar_today

Updated On:

Products

Gen

Issue/Introduction

Will COBOL V4R2 (4.2) work with CA Gen 8.6 applications?  Is it necessary to upgrade to COBOL 5.x or COBOL 6.x?

Environment

Release: 8.6
Components: CA Gen applications, CA Gen z/OS implementation Toolset (IT), CA Gen Host Encyclopedia, CA Gen Construction
COBOL version V4R2

Resolution

Please see the COBOL section of the CA Gen Compatibility Matrix which has the information on which COBOL versions are compatible with CA Gen releases. In particular the 8.6 Info section states:

 CA GEN 8.6 delivers object code compiled using COBOL V5.1.1 for GEN      
 Runtime and COBOL V6.2 for z/OS Implementation Toolset (IT).             
 Language Environment must include Runtime support for these COBOL        
 versions for the GEN object code to APPLY successfully and execute.      

 GEN generated applications can use COBOL V4R2 or later and require       
 LE Runtime support for the version of COBOL used.



Additional explanation:
A COBOL program is compiled by one compiler so all the code in that program is at that specific level/version.
IBM has enabled a COBOL program compiled with one version to call another program compiled with a different version.
IBM also provides support for multiple COBOL runtime versions in the Language Environment (LE), even versions they no longer support. IBM groups all the maintenance required to support each compiler version into Fix Categories to make it easy to find and apply. 
 
In summary, COBOL V4R2 is compatible with CA Gen 8.6 applications:
 -  the required IBM Language Environment (LE) support is installed for the COBOL version 5.1.1 or higher used by the Gen 8.6 runtimes or the COBOL version 6.2 used by the Gen 8.6 z/OS IT.
 -  the required IBM Language Environment (LE) support is installed for the COBOL V4R2 being used as the compiler.
No Gen 8.6 PTFs are required for the COBOL V4R2 support.