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Unable to start Test Data on Demand (TDoD) Service. Service startup Error: TDOD service started on local computer started and then stopped. Some services stop automatically if they are not in use by other services. (GTREP Password changed)

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Article ID: 199290

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Updated On:

Products

CA Test Data Manager (Data Finder / Grid Tools) CA Agile Requirements Designer

Issue/Introduction

Attempting to start the TDoD Service and get this error:

Service startup Error: TDOD service started on local computer started and then stopped. Some services stop automatically if they are not in use by other services. 

Cause

Password used to connect to the TDM Repository database had recently changed.

Environment

Release : 4.6

Component : CA Test Data Manager - Test Data on Demand

ARD v3.0.5.5

TDoD v4.6.0.3

Resolution

Steps to resolve issue:

1. Navigate to C:\Grid-Tools\TDoD\TDoD_ConfigEditor directory

2. Launch the TDoDConfigEditor application (TDoDConfigEditor.exe). The TDoD Config Editor dialog window will open.

3. Typed is new password.

4. Click Verify button validate a successful connection.

5. Click Save button to save the new password value.

6. Click Start Service button.

7. Click Get Service Status to verify service stays up.

8. Bring up Agile Requirements Designer (ARD) Workstation.

9. Choose TDM Repository Connection under Connectors.

10. Was then able to connect to the TDM Repository from ARD.