Hostname is incorrect in NCM Workflow email
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Hostname is incorrect in NCM Workflow email

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Article ID: 199250

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Updated On:

Products

CA Spectrum CA eHealth

Issue/Introduction

When enabling NCM workflow, the email has "OneClick Server Name" instead of the actual OC name 

Approve this task:

https://<OneClick Server Name>:8443/spectrum/ncm/updateWorkflow?wfId=95.24.77.76.2.58.16.0.31.141.192.168.86.245.0.0&wfMgr=com.aprisma.scm.NCMWorkflowManager&status=APPROVED

Deny this task:

https://<OneClick Server Name>:8443/spectrum/ncm/updateWorkflow?wfId=95.24.77.76.2.58.16.0.31.141.192.168.86.245.0.0&wfMgr=com.aprisma.scm.NCMWorkflowManager&status=DENY

 Where can this be changed to update with the actual hostname?

Environment

Release : 10.4.1

Component : Spectrum Applications

Cause

The reason the OC hostname is not in the link is that the SS hos runs on OpenStack which essentially assigns DHCP addresses and in the hosts file, they resolve the server name to the loopback address.

Tomcat attempts to get the server's host name using java generic API InetAddress.getLocalHost(). If tomcat receive the loop back address, then null is returned and tomcat is defaulting <OneClick Server Name> as a host name, indicating tomcat could not retrieve the host name.

Resolution

The emailed link does work if we put the OC Hostname in the link.  This means they'll need to use the GUI or manually edit the link as a workaround and enter it into a browser.

An enhancement has been submitted for future consideration to change the way the hostname is retrieved.