Unable to start Database in Data Repository
search cancel

Unable to start Database in Data Repository

book

Article ID: 199228

calendar_today

Updated On:

Products

CA Performance Management - Usage and Administration DX NetOps

Issue/Introduction

The vertica database will not start and the following error is seen

Unable to read database catalogs - cannot start database.

Database drdata did not start successfully: Unable to read database catalogs

DX NetOps Performance Management Data Repository fails to start.

When I start it via admintools gui it displays no errors and immediately back to the menu.

Starting it via command line I get the following:

dradmin@Node0001 [/opt/vertica/bin] $ ./adminTools -t  start_db -d drdata
Info: no password specified, using none
Unable to read database catalogs - cannot start database.
Database drdata did not start successfully: Unable to read database catalogs

Environment

All supported DX NetOps Performance Management releases

Cause

The ulimit for the dradmin user is misconfigured. It is not set to the required 65536.

Run "ulimit -a" as the dradmin user to determine current settings in your environment.

Resolution

The dr_validate.sh script is normally run to configure the node and set ulimit to 65536.

Run dr_validate.sh and ensure a line like this is observed:

Maximum number of file handles >= 65536 .................................[ OK ]

To manually configure it and start the database:

  1. Log in as the dradmin or equivalent DB admin user.
    • Sample command: su dradmin
  2. Run the following to set the:
    • ulimit -n 65536
  3. Start the database from adminTools