ALERT: Some images may not load properly within the Knowledge Base Article. If you see a broken image, please right-click and select 'Open image in a new tab'. We apologize for this inconvenience.

Wildfly20 WIly Agent Error

book

Article ID: 199199

calendar_today

Updated On:

Products

CA Application Performance Management Agent (APM / Wily / Introscope) CA Application Performance Management (APM / Wily / Introscope) INTROSCOPE DX Application Performance Management

Issue/Introduction

Recently upgraded from jboss-as-7.1.1.Final to wildfly20. We have agent CA Wily Introscope(R) Version 10.5.2 Release 10.5.2.15 installed which was just working fine with Jboss 7. After the Wildfly20 upgrade, we are getting the below error. If I disable the agent then these errors go away.

Any idea How to resolve these errors?

22:01:24,885 ERROR [org.jboss.as.controller.management-operation] (Agent Heartbeat) WFLYCTL0013: Operation ("read-attribute") failed - address: ([
    ("subsystem" => "datasources"),
    ("data-source" => "TestDB")
]) - failure description: "WFLYCTL0216: Management resource '[(\"subsystem\" => \"datasources\")]' not found"

22:01:24,889 ERROR [org.jboss.as.controller.management-operation] (Agent Heartbeat) WFLYCTL0013: Operation ("read-attribute") failed - address: ([
    ("subsystem" => "jca"),
    ("workmanager" => "default"),
    ("short-running-threads" => "default")
]) - failure description: "WFLYCTL0216: Management resource '[(\"subsystem\" => \"jca\")]' not found"

22:01:24,890 ERROR [org.jboss.as.controller.management-operation] (Agent Heartbeat) WFLYCTL0013: Operation ("read-attribute") failed - address: ([
    ("subsystem" => "jca"),
    ("workmanager" => "default"),
    ("short-running-threads" => "default")

Environment

Release : 10.5

Component : APM Agents

Resolution

The highest release supported on all Agents is Wildfly 11. So Wildfly 20 is not supported at this time on any agent. Please open a case to have Support submit a compatibility Guide Request.