Odata Connection Erroring with Username or Password is Invalid
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Odata Connection Erroring with Username or Password is Invalid

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Article ID: 199170

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Updated On:

Products

Clarity PPM SaaS Clarity PPM On Premise

Issue/Introduction

The odata connection is giving a invalid password error for any login attempt. We have validated that everything is set up properly on our side for the OData connection. We can find no reason for this to not be working.

the user is in the oData hDp and all rights are as they should be.

We dropped the Odata and rebuilt it.

Environment

Release : 15.7

Component : CA PPM SAAS OPERATIONS ODATA

Cause

Check to see if REST API calls to PPM endpoint /ppm/rest/v1/auth/authorize are returning an error. If yes, odata is unable to validate the credentials provided.

Resolution

Run curl -v --user admin:password http(s)://hostname/ppm/rest/v1/auth/authorize to check for a HTTP 200 response. If it's not giving HTTP 200 then we have an issue with API authentication.

Steps to Check :

  1. Make sure that the end point /ppm/rest/v1/auth/authorize is un protected if we are using SSO.
  2. Make sure that requests to /ppm/rest/v1/auth/authorize are forwarded to respective servers in the load balancer configuration. 
  3. If the curl command returns any errors, start with restarting the app service and retry the curl test.