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Two different Project Administrators have Reported Security Error: Access Denied. You do not have sufficient permissions to access the content.

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Article ID: 199158

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Updated On:

Products

CA Test Data Manager (Data Finder / Grid Tools)

Issue/Introduction

Users getting this issue on the TDM Portal:
 
Access Denied. You do not have sufficient permissions to access the content.

Both users are admins.

 

Cause

 Issue is happening when the JWT token length is huge due to the huge list of access permissions assigned to the user.   (huge HTTP request header size)

Environment

Release : 4.9

Component : CA Test Data Manager

Resolution

Review this documentation link:

https://techdocs.broadcom.com/content/broadcom/techdocs/us/en/ca-enterprise-software/devops/test-data-management/4-9/administrating/ca-tdm-portal-administration/ca-tdm-portal-troubleshooting.html#concept.dita_9470b0b4a38c9e4ddddc8fdd6f7dce6b4e7c1843_tablesize

Set the "maxHttpHeaderSize" attribute in the Tomcat server.xml to a value of "3000000" (include quotes) and restart the service.

This resolved the issue.