Connection Status Alarm is not visible in Team Center
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Connection Status Alarm is not visible in Team Center

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Article ID: 199142

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Updated On:

Products

CA Application Performance Management Agent (APM / Wily / Introscope) CA Application Performance Management (APM / Wily / Introscope) INTROSCOPE DX Application Performance Management

Issue/Introduction

An alarm that is raised against the value of the Connection Status metric.
An alarm is generated in APM/Introscope when agent is down (disconnected). In Team Center the Agent Card shows 'disconnected' symbol.  However

1.Alarm is not propagated on to the Agent card.
2.The health symbol shows green tick, it is expected to turn red
3.health score shows 100%, it is expected to show 0%

Environment

Application Performance Management 10.7

Cause

The connectionStatus metric which the alarm is trigger against is stored against the collector not the agent


Custom Metric Host (virtual)
  - Custom Metric Process (virtual)
     - Custom Metric Agent (virtual)([email protected])(SuperDomain)
        - Agents
           - Host
              - Process
                  - AgentName:ConnectionStatus

Resolution

Because the alert is not raised against an agent metric it is not possible to map that to Team Center using the teamcenter-status-mapping.properties configuration file. If you wish to visualize the alert then a Webview/Workstation dashboard would be the best option.

Regard point #2 in the description - it will remain green for a short time - then it turns grey.