Error attempting to access ICA's REST API documentation page
search cancel

Error attempting to access ICA's REST API documentation page

book

Article ID: 199083

calendar_today

Updated On: 10-03-2023

Products

Information Centric Analytics Data Loss Prevention Core Package

Issue/Introduction

The Symantec Information Centric Analytics (ICA) Administrator Guide directs users to access additional online help for the REST API via the link <your_symantecICA>/restapi (where <your_symantec> is the hostname of the user's ICA application). Accessing this page returns the following error:

Server Error in '/restapi' Application

Runtime Error

Description: An exception occurred while processing your request. Additionally, another exception occurred while executing the custom error page for the first exception. The request has been terminated.

Cause

The JSON binding redirect in the web.config file for the restapi page was not updated with the 6.5.4 upgrade.

Resolution

To update the web.config file for the restapi page, follow this procedure:

  1. Login to the ICA application (IIS) server as a local administrator, or as a domain administrator with local administration privileges
  2. In Windows Explorer, navigate to the following path:
     %systemdrive%\Program Files\Bay Dynamics\Risk Fabric Server Web\restapi\
  3. Open the file web.config with Notepad or a text editor of your choice
  4. Locate the following section of code:
      <dependentAssembly>
            <assemblyIdentity name="Newtonsoft.Json" culture="neutral" publicKeyToken="30ad4fe6b2a6aeed" />
            <bindingRedirect oldVersion="0.0.0.0-11.0.0.0" newVersion="11.0.0.0" />
          </dependentAssembly>
  5. Change the code to this:
      <dependentAssembly>
            <assemblyIdentity name="Newtonsoft.Json" publicKeyToken="30ad4fe6b2a6aeed" />
            <bindingRedirect oldVersion="0.0.0.0-12.0.0.0" newVersion="12.0.0.0" />
          </dependentAssembly>
  6. Open the File menu and select Save
  7. Open a Command Prompt or PowerShell as an administrator and enter the following commands:
    IISReset /STOP
    IISReset /START