Model(s) Exists Under a Global Collection, But is not Present in a Landscape
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Model(s) Exists Under a Global Collection, But is not Present in a Landscape

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Article ID: 198945

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Updated On:

Products

Spectrum

Issue/Introduction


I've identified a case where a model is searched for on the 'Device Search' box in OneClick, shows up under a global collection but
  not under the Universe on the landscape. The device shows up in a Locator search but the Location menu does not show the
  'Universe' as location.

 

 

Environment

Release : 10.x

Component : Spectrum OneClick

Cause


This can occur when the association from the device to its parent container is removed. In some cases when the device is not a member
   of a Global Collection will not show anywhere in the OneClick console even though the device is present. Often this occurs when a user
   selects 'cut' and does not re 'paste' the device or selects 'remove' on a device.

Resolution


Right-Click on the device where found (Global Collection, Locator Search..etc), select 'Copy', navigate to the landscape and
  container where the device should reside and 'paste' the device into the topology view. This cut & paste option should recreate
  the parent/child association link in the desired location.

 

Additional Information


You can also recreate the association from the device to the parent container it belongs to using the CLI. You will
    need to the model_handle of both the parent container in the landscape and the device. A container will use the
    "Collects" association and will be the left model in the relation.

cd $SPECROOT/vnmsh
./connect

./show relations |grep Collects
Collects                         0x00010002  ONE_TO_MANY

create association rel=Collects lmh=<Container mh>  rmh=<device mh>