CA Business Intelligence (CABI) is integrated with DX Netops Performance Center and the data source status is "Available", but when I launch Reports in Jaspersoft/CABI I receive an error.
search cancel

CA Business Intelligence (CABI) is integrated with DX Netops Performance Center and the data source status is "Available", but when I launch Reports in Jaspersoft/CABI I receive an error.

book

Article ID: 198814

calendar_today

Updated On:

Products

CA Infrastructure Management

Issue/Introduction

CA Business Intelligence (CABI) is integrated with DX Netops Performance Center and the data source status is "Available", but when I launch Reports in CABI I receive an error in a popup similar to:

Unable to load schema version:net.sf.jasperreports.engine.JRException: Response is HttpResponseProxy{HTTP/1.1 500 Server Error [Set-Cookie: JSESSIONID=123jhk1h23jh23kjh2jkhkj2h3jh;Path=/, Expires: Thu, 01 Jan 1970 00:00:00 GMT, Content-Type: application/xml, DataServiceVersion: 1.0, Date: Fri, 28 Aug 2020 14:23:14 GMT, Server: Jetty(8.1.17.v20150415), Content-Length: 237] ResponseEntityProxy{[Content-Type: application/xml,Content-Length: 237,Chunked: false]}}

Error seen in CABI_INSTALL_DIR/apache-tomcat/webapps/jasperserver-pro/WEB-INF/logs/jasperserver.log

Caused by: net.sf.jasperreports.engine.JRException: Unable to load schema version:net.sf.jasperreports.engine.JRException: Response is HttpResponseProxy{HTTP/1.1 500 Server Error [Set-Cookie: JSESSIONID=123jhk1h23jh23kjh2jkhkj2h3jh;Path=/, Expires: Thu, 01 Jan 1970 00:00:00 GMT, Content-Type: application/xml, DataServiceVersion: 1.0, Date: Fri, 28 Aug 2020 14:23:14 GMT, Server: Jetty(8.1.17.v20150415), Content-Length: 237] ResponseEntityProxy{[Content-Type: application/xml,Content-Length: 237,Chunked: false]}}
 at com.ca.capm.jasper.datasource.metadatautils.MetadataKeeper.getSchemaVersion(MetadataKeeper.java:103)
 at com.ca.capm.jasper.datasource.metadatautils.MetadataKeeper.<init>(MetadataKeeper.java:48)
 at com.ca.capm.jasper.datasource.metadatautils.MetadataKeeper.getInstance(MetadataKeeper.java:58)
 at com.ca.capm.jasper.datasource.query.CAPMQueryExecuter.handleQuery(CAPMQueryExecuter.java:127)
 at com.ca.capm.jasper.datasource.query.CAPMQueryExecuter.getDataSourceOfType(CAPMQueryExecuter.java:105)
 at com.ca.capm.jasper.datasource.query.CAPMQueryExecuter.createDatasource(CAPMQueryExecuter.java:89)
 ... 161 more


Checking the following URL as the admin user:

http://<CAPC>:8181/pc/da/odata/api/$metadata

Replace CAPC with the name of the CAPC server and adjust the port/protocol accordingly.

We see:

<error xmlns="http://schemas.microsoft.com/ado/2007/08/dataservices/metadata">
<code/>
<message xml:lang="en-US">A problem has been detected in the metadata provided by the EDM provider.</message>
</error>

Environment

Release : 3.7

Component : IM Data Aggregator

Cause

Jaspersoft CA Business Intelligence uses the DX Netops Performance Management OpenAPI and if there is an issue with that then you can see issues in CABI.

Resolution

This error indicates an issue that is resolved by restarting the odata-services.impl bundle on the Data Aggregator as noted here:

https://knowledge.broadcom.com/external/article?articleId=145105