How do we determine if we are using the latest SPE 7.9 .net sdk?

book

Article ID: 198775

calendar_today

Updated On:

Products

Protection Engine for Cloud Services

Issue/Introduction

How do we determine if we are using the latest SPE 7.9 .net sdk?

Environment

Release : 7.9

Component :

Resolution

Answer:
- Download and examine the Protection Engine material from the BROADCOM support site.

The SPE 7.2.0 archive, contains material for SPE 7.2.0, 7.1.0, and 7.0.0. 
The .zip file Symantec_Protection_Engine_CS_7.9.2.14_Windows_IN.zip contains:
   - Scan Engine
      - Symantec_Protection_Engine_SDK
         - CSharp
            - symcsmsnetapi.dll

 

  1. Extract symcsmsnetapi.dll
  2. In Windows Explorer. right click on symcsmsnetapi.dll
  3. Click Details

 

File version contains "7.9.1.1" whether extracted from either Symantec_Protection_Engine_CS_7.9.2.14_Windows_IN.zip or Symantec_Protection_Engine_CS_7.9.1.12_Windows_IN.zip.

This methodology would be similar for each of the subsequent code branches of SPE.