DX Infrastructure Manager - ntperf doesn't start

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Article ID: 198758

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Updated On:

Products

CA Unified Infrastructure Management On-Premise (Nimsoft / UIM) NIMSOFT PROBES DX Infrastructure Management

Issue/Introduction

After deploy ntperf probe to a Windows 2008 box, the ntperf64 is started ok, but ntperf is not. The ntperf log only show next message:

Sep  2 13:27:04:901 [2492] Controller: Max. restarts reached for probe 'ntperf' (command = ntperf.exe)

Cause

After set loglevel 5 and logsize 100,000 in controller probe, and start the ntperf manually next is logged in controller.log:

Sep  3 13:36:39:405 [1088] 1 Controller: Probe 'ntperf' started (pid=3176)
...
Sep  3 13:36:40:403 [1088] 1 Controller: Process stopped (probe=ntperf, pid=3176) RET = -1073741515
...
Sep  3 13:36:41:402 [1088] 1 Controller: Probe 'ntperf' started (pid=2460) (restart 1)
....
Sep  3 13:36:42:088 [1088] 1 Controller: Process stopped (probe=ntperf, pid=2460) RET = -1073741515
Sep  3 13:36:43:804 [1088] 1 Controller: Probe 'ntperf' started (pid=4060) (restart 2)
...
Sep  3 13:40:05:248 [1088] 1 Controller: Probe 'ntperf' started (pid=4956) (restart 11)
...
Sep  3 13:40:06:028 [1088] 1 Controller: Process stopped (probe=ntperf, pid=4956) RET = -1073741515

After the 11th restart, the controller stop trying to start the probe.
The important here is the Return code: -1073741515
File System Error 1073741515, also known as error 0xC0000135, is associated with registry issues and missing dll files.

Environment

Release : 20.1

Component : UIM NTPERF

Resolution

To resolve the problem, please deploy (again, if it was already deployed) to this robot,

1. vs2017_vcredist_x64 
2. vs2017_vcredist_x86
3. After a successful deployment of these probes, attempt to start the ntperf probe again. This time it should start without issue. 

Additional Information

update from 8.51 to 9.0.2 failed with error
https://knowledge.broadcom.com/external/article?articleId=127520