Request status not updated and history is empty

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Article ID: 198717

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Updated On:

Products

CA Service Management - Asset Portfolio Management CA Service Management - Service Desk Manager

Issue/Introduction

Product: Service Catalog 17.2

"Service Catalog Request status change history  and audit trail are empty even though policy is evaluated and status is Pending approval"

On Service Catalog, request was opened and policy engine was evaluated. Status is pending approval and customer received approval email.

After approving, nothing happened. The request status was not updated and the history is empty as well as audit trail.

Cause

Client running on old patch level i.e. 17.2.0.2

Environment

Release : 17.2
Component : CA SERVICE CATALOG

Resolution

Suggested to upgrade to the latest patch level i.e. RU09

WIN-CASM 17.2.0.9 ROLLUP PATCH (REQUIRES 17.2)

Link: https://support.broadcom.com/download-center/solution-detail.html?aparNo=SO14581&os=WINDOWS

Additional Information

Noted a fix in RU3 (DE49256) - which stated "Unable to update the usm_request_pending_action table, as a result, pending actions view contains requests which are already approved. This behavior is noticed when the pending action is assigned to several contacts for approval."