Error 500 when filtering on portlets / portlet hangs due to DB issue

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Article ID: 198639

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Updated On:

Products

Clarity PPM SaaS Clarity PPM On Premise

Issue/Introduction

Post migration to GCP/Postgres, we see issues with multiple custom Timesheet portlets where they hang (slow performance) or we get error 500 when filtering. 

Cause

This can be due to a Database (DB) issue including stale statistics on tables used by the portlet (PRTIMEENTRY, PRTIMESHEET & PRASSIGNMENT tables)

Environment

Release : All Supported Releases

Component : CA PPM SAAS STUDIO

Resolution

On Premise customers:

  • Have the DBA gather stats manually on the impacted tables which should correct the issue

SaaS customers:

  • Please contact Broadcom support for assistance

Note: See the additional information section for other known causes as well. 

Additional Information