javax.security.auth.login.LoginException for all users
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javax.security.auth.login.LoginException for all users

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Article ID: 198606

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Updated On:

Products

CA Identity Manager CA Identity Governance CA Identity Portal CA Identity Suite

Issue/Introduction


The CA Identity Portal (Sigma.war) is writing a lot of content to the log files, for example: 

javax.security.auth.login.LoginException: User:testuser, is not an Portal Admin.
        at com.idmlogic.sigma.manager.impl.PortalAdminsManagerBean.mainConnectorSSOLogin(PortalAdminsManagerBean.java:116)
        at com.idmlogic.sigma.manager.impl.PortalAdminsManagerBean.ssoLogin(PortalAdminsManagerBean.java:57)
        at sun.reflect.GeneratedMethodAccessor966.invoke(Unknown Source)
        at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
        at java.lang.reflect.Method.invoke(Method.java:498)
        at org.springframework.aop.support.AopUtils.invokeJoinpointUsingReflection(AopUtils.java:302)
        at org.springframework.aop.framework.ReflectiveMethodInvocation.invokeJoinpoint(ReflectiveMethodInvocation.java:190)

 

Environment

Release : 14.3 CP2 with SSO integration hosted on a Weblogic application server

Component : CA IDENTITY MANAGER

Cause

This is caused by a Weblogic configuration issue.



Resolution

The Weblogic application server was configured with a high log level causing it to write a lot of log data. Reducing the log level removes many of the benign messages.