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SpectroSERVER hanging after upgrading

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Article ID: 198550

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Updated On:

Products

CA Spectrum

Issue/Introduction

After upgrading the SpectroSERVER, the SpectroSERVER hangs when running a backup or trying to shutdown.

Environment

Release : Any

Component : Spectrum Core / SpectroSERVER

Cause

Possible issue of processd not creating runtime tickets for the Spectrum processes.

Check the $SPECROOT/lib/SDPM/processd_log file for errors similar to the following:

Sep 01 10:06:33 CAN'T CREATE THE TICKET IN CSPROCDDB DATABASE !
Sep 01 10:09:22
Client Name: SpectroSERVER
User Name  : spectrum( 800 )
Host       : spectrum ( 192.168.2.1 )

Check the $SPECROOT/lib/SDPM/runtime directory for runtime (rtt) files

Resolution

1. Log into the system as the user that owns the Spectrum installation

    a. If on Linux, su to the root user

    b. If on Linux, start a bash shell by running "bash -login"

2. cd to the $SPECROOT/lib/SDPM directory and enter the following command to restart processd:

./processd.pl restart

3. Check the $SPECROOT/lib/SDPM/processd_log file for the errors

4. Check the $SPECROOT/lib/SDPM/runtime directory for runtime (rtt) files

Additional Information

Starting in Spectrum 10.4.2.1, processd.pl script will now also stop the SpectroSERVER and Archive Manager when using the "restart" option:

https://knowledge.broadcom.com/external/article?articleId=201598