WA DE Server start up failure - java.net.UnknownHostException

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Article ID: 198404

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Updated On:

Products

CA Workload Automation DE - Business Agents (dSeries) CA Workload Automation DE DSERIES- SERVER CA Workload Automation DE - System Agent (dSeries) CA Workload Automation DE - Scheduler (dSeries)

Issue/Introduction

CA Workload Automation DE Server startup failure with the following message in the stdout.txt:

[email protected]:/usr/local/esp/EspServer/logs> more stdout.txt
The server PID file is /usr/local/esp/EspServer/serverPID
java.net.UnknownHostException: standby.server.net
        at java.net.InetAddress.getAllByName0(InetAddress.java:1281)
        at java.net.InetAddress.getAllByName(InetAddress.java:1193)
        at java.net.InetAddress.getAllByName(InetAddress.java:1127)
        at java.net.InetAddress.getByName(InetAddress.java:1077)
        at com.cybermation.espresso.bootstrap.ServerMain.startRmiRegistry(ServerMain.java:817)
        at com.cybermation.espresso.bootstrap.ServerMain.main(ServerMain.java:400)

CA Workload Automation Server failed to start : java.net.UnknownHostException: standby.server.net

CA Workload Automation Server has shutdown

Terminated.

 

Cause

One of the following could be the reason for the error in CA Workload Automation DE environments - 

  • Mostly the exception "java.net.UnknownHostException" is due to the DNS name resolution
  • Incorrect hostname entry in the DE server's configuration or in the instance properties file
  • If the DE was moved to a new server which has new IP/hostname then DB will have entry for old hostname and it will not match

Environment

Release: CA WORKLOAD AUTOMATION DE (DSERIES) R12.x

Resolution

  • Ensure the DE server (primary and standby) hostname resolves properly.
  • Users can verify the hostname resolution with: nslookup <hostname>
  • The database stores the DE server hostnames (both primary and standby for High Availability or HA).

select * from esp_config_property where name = 'espresso.local.host'

The IN_USE_1, IN_USE_2, DESIRED fields will have to be updated with new hostname.
 
UPDATE ESP_CONFIG_PROPERTY SET IN_USE_1='new_name', IN_USE_2='new_name', DESIRED='new_name' WHERE IN_USE_1='old_name';
         
Note:  It is recommended to take full database backup before making any changes.  For HA, there will be two entries in the ESP_CONFIG_PROPERTY.  Change the Primary server first, this can be identified as 101 in config_group_id.  The second entry for espresso.local.host is normally for Standby as it is usually installed after Primary.  Once Primary hostname has been update, update the Standby hostname (see above SQL example).
 
E.g. Showing two entries in the database for HA setup.  Here config_group_id 101 is Primary, and 104 is for standby.
 
     id  | config_group_id|        name         |    in_use_1      |      in_use_2   |    desired             
----------------------+---------------------+--------------------------------+------------------------
  109 |      101 | espresso.local.host | prod.de.local    | prod.de.local   | prod.de.local
  222 |      104 | espresso.local.host | standby.de.local | standby.de.local| standby.de.local 
 
Once the update has been done, start DE Primary server then Standby.