Issue:
Values are missing from either PPA_WIP.EXTERNALBATCHID or PRTIMEENTRY.INCIDENT_ID and PRTIMEENTRY.INCIDENT_INVESTMENT_ID so that it is not possible to query for PPA_WIP records with its origin back to the incidents that are used on timesheets.
If the option is checked from Administration, Project Management: Settings, 'Allow Effort Task Creation' :
- The PRTIMEENTRY table does have the incident's ID stored in the INCIDENT_ID and INCIDENT_INVESTMENT_ID columns.
- However the PPA_WIP table stores NULL for columns EXTERNALBATCHID which is expected to be the PRTIMESHEET.PRID for the timesheet where hours are posted for the incident.
If the 'Allow Effort Task Creation' option is NOT checked:
- The PPA_WIP table stores the correct PRTIMESHEET.PRID for the timesheet where hours are posted for the incident in the EXTERNALBATCHID column
- However the PRTIMEENTRY table stores NULL in the INCIDENT_ID and INCIDENT_INVESTMENT_ID columns.
Steps to Reproduce:
- Check the option at Administration, Project Management: Settings, 'Allow Effort Task Creation' (checkbox), click 'Save' button
- Create a resource, mark the resource for Open for Time Entry, track mode set to 'Clarity' or 'PPM'
- Financially enable the resource by saving Department, Location, Resource Class and Transaction Class on the Financial Properties page, check the box for "Financial Properties Active". Submit
- Create a new category from Administration, Incidents, Categories
- Create a new incident using the category created above
- Create a new NPIO, such as an Asset named "Asset One". Mark the asset as 'Open for Time Entry' and set Track Mode
- Staff the resource created above to this asset; then financially enable the asset by setting Financial status to 'Open', and populating the Department and Location OBS fields on the Financial Properties setting page
- Add the incident to the asset from the asset Incidents sub page
- Log some hours for the resource again the incident "Incident 5001" using the 'Add Incident' button on the timesheet, submit, approve and post the timesheet
- Run Post Incident Actuals job
- Query the PRTIMEENTRY table for the timesheet created above
Expected Result: INCIDENT_ID and INCIDENT_INVESTMENT_ID columns have values corresponding to the incident internal ID, and the asset internal ID respectively
Actual Result: both columns show NULL value, there is no way to know which incident the timesheet hours have come from - Uncheck the box from Administration, Project Management: Settings, 'Allow Effort Task Creation' (checkbox), 'Save'
- Repeat steps from 4 through 11
- Now both PRTIMEENTRY.INCIDENT_ID and PRTIMEENTRY.INCIDENT_INVESTMENT_ID now have correct values
- Query PPA_WIP
Example query:
select * from ppa_wip where project_code = 'ASSET_TWO'
-- note this is the code for the second asset
-- note you will not find this transaction from the Create WIP Adjustment page in Clarity, this is as expected because the task ID is null
Expected Result: PPA_WIP.EXTERNALBATCHID has the same value as PRTIMESHEET.PRID
Actual Result: PPA_WIP.EXTERNALBATCHID is null, there is no way to know which timesheet this transaction has come from
Cause:
Caused by CLRT-73023
Resolution:
Our sustaining team reviewed CLRT-73023 and closed it as they are not planning to make any changes to this area of the product in the reported version.
This issue does not impact overall stock financial functionality, but without this information in the WIP tables, it cannot provide references to the incident for use in user-defined queries.
Workaround:
None.
Additional Information:
For more details please review the Customer Reported Defect Resolution Policy for CA PPM