Clarity: PowerBI Report breaks after migrating to Google Cloud Platform

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Article ID: 198247

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Updated On:

Products

Clarity PPM SaaS

Issue/Introduction

Post migration to Google Cloud Platform the ODATA is giving below error 

Steps to reproduce:

  1. Open an existing ODATA built in Power BI Report
  2. Update ODATA connection on an existing report built in Power BI

Expected Result: ODATA connection establish and report refreshes.

Actual Result: ODATA connection established but report returns with error

 

Cause

In old data center the table and column name using ODATA Connection was in UPPER CASE and in Google Cloud Platform with PostgreSQL its lowercase and thats why you get error 

 

Environment

Clarity hosted in Google Cloud Platform

Resolution

1. Open an existing ODATA built in Power BI Report

2. Update ODATA connection on an existing report built in Power BI

3. Step “CHANGE_CASE_TO_UPPER” inserted after the Source, Navigation and ExpandTableColumn (if used) steps.

4. Make sure the Step immediately following references the new inserted step

6. Step "CHANGE_CASE_TO_UPPER"  inserted after the Source, Navigation and Expand of TableColumn (if used) steps 

Additional Information

Note:

  • This document explains taking example of Microsoft PowerBI but this will impact any other ODATA Client tools and customer needs to modify the report as in PostgreSQL the column and table name will be in lowercase 
  • If you build a new report you will not need to do this change as all the column name will be in lower case 

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