Application models not created in Spectrum even though the device supports the required mibs

book

Article ID: 198228

calendar_today

Updated On:

Products

CA Spectrum

Issue/Introduction

Application models not created in Spectrum even though the device supports the required mibs

Cause

Possible root cause of the issue is Spectrum is timing out when reading a table from the mib before the end of table (eot) is reached. By default, Spectrum will only wait 5 seconds for the eot. If not received within 5 seconds, Spectrum stops reading the table and the application model is not created.

Environment

Release : Any

Component : Spectrum Modeling

Resolution

Use the Model Type Editor (MTE) to increase the value of the eot_limit attribute id 0x0023obd2 for the device Model Type where this issue is seen.

The following instructions use the FortinetFortiOS device Model Type as an example:

1. Log into the SpectroSERVER system as the user that owns the Spectrum installation

2. Shutdown the SpectroSERVER process

3. On Windows, start a bash shell by running "bash -login"

4. cd to the $SPECROOT/SS directory and enter the following command to start MTE:

../SS-Tools/mte -logging 

(See the note in the Additional Information section for information on the "-logging" parameter when starting MTE.)

5. Find the FortinetFortiOS model type

6. Find and select the eot_limit attribute id 0x0023obd2

7. Change the value from 5 to 100

8. Save the changes and exit MTE

9. Start the SpectroSERVER as normal and model the device to see if the application models are created as expected.

Additional Information

Using the "-logging" parameter creates an xml file that contains information on the catalog changes done using MTE. This xml file can then be used to import these changes into another SpectroSERVER database using the dbtool application without having to use MTE. 

Reference knowledge article 121348 "How to propagate catalog changes in a Distributed SpectroSERVER environment" for more information.