Provisioning Server unable to start
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Provisioning Server unable to start

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Article ID: 198214

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Updated On: 10-11-2023

Products

CA Identity Manager CA Identity Governance CA Identity Portal CA Identity Suite

Issue/Introduction

Provisioning Server is unable to start.

Reviewing the etatrans.log we see the following error
20200826:135843:TID=0015d8:Config    :----:----:*: Error: ETA::Configuration failed to find attribute <Connector Servers/CCS_XYZXIAM
20200826:135843:TID=0015d8:Config    :----:----:*:+001_TLS_20403/Managed Branches>.
20200826:135843:TID=0015d8:Config    :----:----:*: Please report the error.
 
Another variation of the error could be

Error: ETA::Configuration failed to find xxx.
Please report the error.

(without any mention of a specific attribute)

 

Environment

Release : 14.x

Component : IdentityMinder(Identity Manager)

Cause

Data inconsistency is stopping the Provisioning Server from obtaining the config data.

Resolution

In order to resolve this error and allow Provisioning Server to start, we need to address the data inconsistency.

We need to

1. use an LDAP browser and connect to the Provisioning Directory over port 20391

Base DN: dc=etadb

User DN: eTDSAContainerName=DSAs,eTNamespaceName=CommonObjects,dc=etadb
(The password is set during the provisioning directory installation)

2. Navigate to eTConfigParamFolderName=Connector Servers,eTConfigParamContainerName=Parameters,eTConfigContainerName=Configuration,eTNamespaceName=CommonObjects,dc=XX,dc=etadb

3. Check the entries associated with the connector server mentioned in the error. We would expect each CS entry to have 4 branches, each with its own attributes

4. The inconsistency should either be addressed (missing attributes from a backup) or the CS entry to be removed altogether

Please ensure to keep a backup of the DSA before making any changes.