WAAE 11.3.6 SP8 DVD01136SP8E.iso installation error on Oracle Linux 7.6 Please check that the correct system libraries are used (libc, libstdc++).

book

Article ID: 198192

calendar_today

Updated On:

Products

CA Workload Automation AE - Business Agents (AutoSys) CA Workload Automation AE - System Agent (AutoSys) CA Workload Automation AE - Scheduler (AutoSys) CA Workload Automation Agent CA Workload Automation AE

Issue/Introduction

We are trying to install WAAE on an Oracle Linux 7.6 and received the following error:

# ./wa_setup.sh 
Error: binary file lsm.exe cannot be executed
Please check that the correct system libraries are used (libc, libstdc++).

So we have upgraded from libstdc++.x86_64 4.8.5-36.0.1.el7 to libstdc++-4.8.5-39.0.5.el7.x86_64

This is what we currently have installed:

# yum list installed | grep libc

glibc.i686                             2.17-307.0.1.el7.1          @ol7_latest  
glibc.x86_64                           2.17-307.0.1.el7.1          @ol7_latest  
glibc-common.x86_64                    2.17-307.0.1.el7.1          @ol7_latest  
glibc-devel.x86_64                     2.17-307.0.1.el7.1          @ol7_latest  
glibc-headers.x86_64                   2.17-307.0.1.el7.1          @ol7_latest  
libcacard.x86_64                       40:2.5.2-2.el7              @anaconda/7.4
libcanberra.x86_64                     0.30-5.el7                  @anaconda/7.4
libcanberra-gtk2.x86_64                0.30-5.el7                  @anaconda/7.4
libcanberra-gtk3.x86_64                0.30-5.el7                  @anaconda/7.4
libcap.x86_64                          2.22-9.el7                  @anaconda/7.4
libcap-ng.x86_64                       0.7.5-4.el7                 @anaconda/7.4
libcdio.x86_64                         0.92-3.el7                  @ol7_latest  
libcdio-paranoia.x86_64                10.2+0.90-11.el7            @anaconda/7.4
libcgroup.x86_64                       0.41-20.el7                 @ol7_latest  
libchamplain.x86_64                    0.12.16-2.el7               @ol7_latest  
libchamplain-gtk.x86_64                0.12.16-2.el7               @ol7_latest  
libchewing.x86_64                      0.3.4-6.el7                 @anaconda/7.4
libcollection.x86_64                   0.7.0-32.el7                @ol7_latest  
libcom_err.x86_64                      1.42.9-13.el7               @ol7_latest  
libconfig.x86_64                       1.4.9-5.el7                 @anaconda/7.4
libcroco.x86_64                        0.6.12-4.el7                @ol7_latest  
libcurl.x86_64                         7.29.0-51.el7               @ol7_latest  
 

# yum list installed | grep libstdc
libstdc++.x86_64                       4.8.5-39.0.5.el7            @ol7_latest  
 

Environment

Release : 11.3.6

Component : CA Workload Automation AE (AutoSys)

Resolution

We have the following information in the Notes for Oracle Linux 7 in server supported versions. We need the following 32-bit libraries to be installed before attempting to run wa_setup.sh

compat-libstdc++-33 or higher is required. The 32-bit version is required on the 64-bit version of Linux.

libstdc++.so.5 and libstdc++.so.6 or higher are required.
The libstdc++.so.5 shared library is contained in the compat-libstdc++ rpm package.
The libstdc++.so.6 shared library is contained in the libstdc++ rpm package.

libuuid.so.1 is required. The 32-bit version is required on the 64-bit version of Linux.
libaio.so.1 is required. The 32-bit version is required on the 64-bit version of Linux.
libbz2.so.1 is required. This library is contained in the bzip2-libs rpm package. The 32-bit version is required on the 64-bit version of Linux.

Perl version 5.8 or higher is required.
ncurses (32-bit) version 5 or higher is required on the 64-bit version of Linux.

glibc 2.4 (32-bit) or higher is required.
libgcc-4.4 (32-bit) or higher is required.
nss-softokn-freebl-3.12 (32-bit) or higher is required.
The pam.i686 0:1.1.8-12.el7_1.1 rpm package is required on the 64-bit version of Linux.
Both UEK and RedHat Kernels are supported.

Additional Information

Server Supported Versions