SPE slow scan
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SPE slow scan

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Article ID: 198161

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Updated On:

Products

Protection Engine for Cloud Services

Issue/Introduction

With an ICAP scan request sent to Symantec Protection Engine (SPE), a file scan is taking more than 3 minutes even for the very small file of size 6KB.

This slow scan times out the File Upload feature from the web application which sends ICAP requests to SPE for file scans.

+ When testing with the cli test tool ssecls, ssecls output shows a scan rate with a unit of bytes/sec which is very slow.

+ The ssecls test scan run locally on the SPE box, eliminating the possibility of slow network communication contributing to the slow scan

+ In Internet Explorer 11, SPE User Interface (UI) displays a blank page

 

 

Environment

+ SPE is installed in a Virtual Machine (VM)


+ Less than 4 CPU cores are assigned to the guest VM where SPE is installed, as shown by one of the two following commands from within the guest VM: 
   Windows PowerShell CLI:
      WMIC CPU Get DeviceID,NumberOfCores
   Linux bash CLI:
      nproc

 

 

Cause

Insufficient CPU resources

 

 

Resolution

Please add (and reserve!) CPU resources to the virtual machine where SPE is installed.

Reinstalling SPE will correct these symptoms for no longer than 10 minutes, then the slow scan symptoms will occur again.

 

 

Additional Information