VIP Desktop Credential error: failed to start because its side-by-side configuration is incorrect
search cancel

VIP Desktop Credential error: failed to start because its side-by-side configuration is incorrect

book

Article ID: 198124

calendar_today

Updated On:

Products

VIP Service

Issue/Introduction

VIP Desktop Credential fails to launch with error: "The application has failed to start because its side-by-side configuration is incorrect. Please see the application event log or use the command-line sxstrace.exe tool for more detail."

Cause

The "side-by-side" error is usually caused by an incorrect/missing Visual C++ library. 

Microsoft Visual C++ 2022 Redistributables (x64 and x86 on 64-bit platform, x86 on 32-bit platform) must be deployed/installed separately prior to VIP Access Desktop deployment. Symantec recommends to download Microsoft Visual C++ 2022 Redistributable Package from Microsoft website.

Alternatively, this file is available for download from VIP Manager > Account (Tab) > Download Files > VIP Access Desktop > Windows > VIP Access package  (VIPAccess_2_2_5.zip).

Resolution

Install, repair, or re-install the Microsoft Visual C++ 2022 Redistributables

If the problem persists, then do a complete uninstall/re-install of the VIP Desktop Application after correcting this pre-requisite:

  1. Uninstall the program through Control Panel > Add/Remove programs and click "yes" to remove Credential information.
  2. Delete the Windows User Registry key: [HKEY_CURRENT_USER\SOFTWARE\Symantec\VIP Access Client]
  3. Delete the Windows Installer Registry Key:  [HKEY_LOCAL_MACHINE\Software\Classes\Installer\Products\{find key with "VIP Access" in ProductName}]
  4. Delete Local user files: C:\Users\{user profile}\AppData\LocalLow\Symantec\VIPAccessClient
  5. Re-install VIP Desktop and ensure you are using the latest VIP installation files from https://vip.symantec.com/

Attachments

1598452496477__VIPAccess_ReleaseNotes_2_2_4.pdf get_app