FDM Unable to mask database Table. Rows not updated

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Article ID: 198054

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Updated On:

Products

CA Test Data Manager (Data Finder / Grid Tools)

Issue/Introduction

Data masking is getting completed but rows are not getting updated.  No masking is taking place according to the database.

100 testers will get affected after tomorrow, if data would not be available. 

Cause

This is not a TDM tool issue.  In order for the SQL Manager to even see the data or the row count, a context or view had to be triggered to allow data to be exposed to the user's session.  Enabled DEBUG at DIAGLEVEL=4 and the only thing logged was the contents of the OPTION file.  This indicated that even though the context was run against table, it was session based and not persisted for all users that accessed that table.  A new context will have to be created by the DBA to allow access.

Environment

Release : 4.9

Component : CA Test Data Manager

Database: ORACLE

Resolution

Could not see the data from SQL Manager. Had to have a Context triggered to see the data. A new context had to be created that would be triggered whenever a user/FDM logged onto the table schema. Their DBA created it, tested it, re-ran the FDM job, and it worked.  Not much more can be stated about this event as this is highly proprietary in nature.