The output from one job is displayed as different entries (sysout groups) in CA View instead of showing as one.
search cancel

The output from one job is displayed as different entries (sysout groups) in CA View instead of showing as one.

book

Article ID: 198016

calendar_today

Updated On:

Products

Deliver View

Issue/Introduction

The output from the same job is displayed in CA View as multiple sysout groups instead of showing as one, so it looks as if the job was run multiple times.

 

Environment

Release : 14.0

Component : CA View

 

Cause

CA View SYSOUT is archived in units called SYSOUT groups. A SYSOUT group is comprised of one or more SYSOUT data sets, for a job, that have the same attributes (for example, the same SYSOUT ID, the same SYSOUT class, the same forms name, and the same FCB) and are presented to CA VIEW sequentially. Any change in attributes will cause the current SYSOUT group to be closed and a new SYSOUT group allocated. Once a SYSOUT group is closed, it will not be reopened to receive more output.

This could also occur if there is any delay in the time the output is available. CA View will request output from JES for the same sysout group until there are no more sysout data sets available It will then close the sysout group. Since it cannot reopen a sysout group, if another data set becomes available, it will allocate a new sysout group, but the new group will have the same jobname, JESID number, date, time, etc., as the original.

 

 

Resolution

CA View requests work from JES sequentially, but whenever the output attributes change, it closes the entry being worked on and opens another.

No action is needed, this is the way the product works.