Illegal HTML character error in XOG

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Article ID: 198014

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Updated On:

Products

Clarity PPM On Premise Clarity PPM SaaS

Issue/Introduction

When loading an XML with XOG, the following error is logged:

<ErrorInformation><Severity>FATAL</Severity><Description>Exception while processing client request</Description><Exception type="com.niku.xog.XOGException">Input document contains Illegal HTML character for object application</Exception></ErrorInformation>

Cause

An invalid character is present in the xml file. This can include non english characters. 

Environment

Release : All Supported

Component : Clarity XML Open Gateway (XOG)

Resolution

The error message does not note the location of the bad character, so unfortunately a review of the load file will be the only method from a Clarity support perspective to determine where the character is located.

  1. One suggestion is to try to reduce the size of the xml to help limit the amount of information to review. For example, split the load file in half and determine which of the two halves fails, and continue this until you have a manageable amount of information to review.
  2. A XSLT tool may also help to remove NLS elements from the XOG file where the language is not ‘en’ if the issue is due to non English Characters. One XSLT tool referenced in communities post" Great new XOG tool - check it out! may be able to assist (or other similar tools) - Note that these are not supported by Clarity Support. It's recommended to test any XOG changes in non production first.

Additional Information

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