need to check the OS compatiblibility for siteminder upgrade

book

Article ID: 198008

calendar_today

Updated On:

Products

CA Single Sign On Secure Proxy Server (SiteMinder) CA Single Sign On Agents (SiteMinder) CA Single Sign On Federation (SiteMinder) CA Single Sign On SOA Security Manager (SiteMinder) SITEMINDER

Issue/Introduction

 

We're planning an upgrade, and we'd like to know if we can run an
In-Place upgrade for the Policy Server, if we upgrade it from 12.7SP2
to 12.8SP3 on RedHat 7 ?

 

Environment

 

Policy Server 12.8SP3 on RedHat 7;

 

Resolution

 

At first glance, the warning from the "Upgrade Policy Server" document
concerns only when the Policy Server to upgrade is version 12.5x,
which is 12.5, 12.51. 12.52, 12.52SP1, 12.52SP2 :

  Upgrade Policy Server

    This content describes how to upgrade a 12.5x or later Policy Server
    to 12.8.x.  

    Warning

      The 12.8.x Policy Server is a 64-bit executable and requires a
      supported 64-bit operating system. You can therefore only upgrade an
      existing Policy Server running on Windows Server 2012 R2, or Red Hat
      Enterprise Linux 6. If your Policy Server is running on another
      operating system, you must perform a fresh installation on Windows
      Server 2012 R2, Windows 2016, Red Hat Enterprise Linux 6, or Red Hat
      Enterprise Linux 7. If you must install a new 12.8.x Policy Server,
      the 12.8.x Policy Server can point it to an existing policy store. The
      store has to include a CDS or have been extended to include a CDS.

  https://techdocs.broadcom.com/content/broadcom/techdocs/us/en/ca-enterprise-software/layer7-identity-and-access-management/single-sign-on/12-8/upgrading/in-place-upgrade/upgrade-policy-server.html

As per 12.52 Support Matrix, Policy Server had no support on RedHat 7,
that's why the above warning :

  CA SiteMinder 12.52 Product Support Matrix

    2.1 Operating System for Policy Server & Secure Proxy Server (SPS)

      | CA SiteMinder | Red Hat |
      | Component     |         |
      |---------------+---------|
      | Policy Server |       6 |
      |               |       5 |

      p. 2

  https://ftpdocs.broadcom.com/phpdocs/7/5262/5262_SiteMinder_12_52_SP1_Platform_Support.pdf

And this warning doesn't concern the 12.7SP2 Policy Server as it is
already supported on RedHat 7 :

  CA Single Sign-On 12.7 Product Support Matrix

    2.1 Operating System for Policy Server & Access Gateway

      | CA Single Sign-  | Red Hat |
      | On Component     |         |
      |------------------+---------|
      | Policy Server 64 |       7 |
      | bit              |       6 |

      p. 2

   https://ftpdocs.broadcom.com/phpdocs/7/5262/5262-12-7-platform-support-matrix.pdf

Note that upgrading to 12.8SP3, you'll need to install AdoptOpenJDK
and uninstall the Oracle JDK you ran with 12.7 :

2.4 Java Virtual Machine (JVM)
  
  Review this section carefully. The Java support has been changed as
  of the release of 12.8.03.

  The following table lists the Java Virtual Machine (JVM) support
  requirements for release 12.8.03:

  | SiteMInder Component | Java Runtime Environment                         |
  |----------------------+--------------------------------------------------|
  | Policy Server        | AdoptOpenJDK 1.8.212 (or later updates on 1.8.x) |
  |                      | 64 bit                                           |

  p. 8

https://ftpdocs.broadcom.com/phpdocs/7/5262/5262-12-8-platform-support-matrix.pdf

So you can upgrade the Policy Server 12.7SP2 running on RedHat 7 to
12.8SP3 on the same machine (In-Place Upgrade).