Integration between CA PAM and CA Treat Analytics does't work
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Integration between CA PAM and CA Treat Analytics does't work

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Article ID: 197921

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Updated On:

Products

CA Privileged Access Manager (PAM) CA Privileged Access Manager - Cloakware Password Authority (PA) CA Privileged Access Manager - Server Control (PAMSC)

Issue/Introduction

When trying to integrate CA PAM with CA Threat Analytics in the next step:

"Specify the CA Threat Analytics Server to Use 
Specify the CA Threat Analytics service that receives the user data from PAM for processing.

Follow these steps on each instance:
  • Log in to the 
    PAM
     UI and navigate to 
    Configuration
    ,
     CA Modules, CA Threat Analytics.
  • Enter values for the following fields:
     
  • Threat Analytics Address:
     Enter an IP address or FQDN for the server hosting the service.
  • Threat Analytics Auth Token: 
    Enter the authentication token string that is generated by the CA Threat Analytics server. Get this string from the Threat Server administrator. This token is analogous to a password for access to that server.
  • Threat Analytics Service ID:
     Enter the service identifier string that is generated by the CA Threat Analytics server. Get this string from the Threat Server administrator. This identifier is analogous to a username for the server.
     
  • Optionally, turn 
    SSL Validation off
    , select this checkbox. This option is useful for testing.
     
    • Select
       Save
      .
    • Test the validity of the connection by selecting 
      Test
      . Wait for a configuration message that the connection is successful."

      Shows the error:

      PAM-CMN-2032: BAPService.getRiskLevels called when CA Threat Analytics was not configured. Request ignored.







      Environment

      Release : 3.4

      Component : PRIVILEGED ACCESS MANAGEMENT

      Cause

      It is a problem of the order in which the token for TAP and the test of the integration is done.

      Resolution

      First hit "save" then "test" when configuring integration in PAM UI (Configuration --> CA Modules --> threat Analytics). That it, first save the token, wait for some minutes and then hit the test button.