SpectroSERVER crash in the middle of the upgrade to 10.4.2

book

Article ID: 197920

calendar_today

Updated On:

Products

CA Spectrum

Issue/Introduction

The primary MLS has been upgraded from 10.3.2 to 10.4.2 successfully.

While shutting down another primary SS in DSS environment, it crashed. Restored a previous healthy SSdb backup and tried to start the SpectroSERVER to validate the SSdb, but while activating the model in 99% and almost to be in Running state, it crashed. It crashes with any SSdb copy, even from last month.

Cause

Cannot start an older release of Spectrum in a DSS environment when the MLS has already upgraded to a newer release. Mixed Spectrum release is not supported.

Environment

Release : 10.3

Component : Spectrum Core / SpectroSERVER

Resolution

As a workaround, set the Location Server to point to itself, and the SpectroSERVER started successfully to validate the restored SSdb in 10.3.2 release.

Stop the SS, set back the original setting in Location Server, and upgrade to 10.4.2 release.