Error accessing offering "You do not have access to make requests"

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Article ID: 197899

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Updated On:

Products

CA Service Management - Asset Portfolio Management CA Service Management - Service Desk Manager

Issue/Introduction

Product: Service Catalog
 
Issue: On accessing an offerings they are bringing back an Error "You do not have access to make requests."
This happens for all offerings. 

Cause

ERROR Exception while communicating with the database:The ALTER TABLE statement conflicted with the FOREIGN KEY constraint "$usm_r_r000029af00000000". The conflict occurred in database "mdb", table "dbo.usm_rule_event_type", column 'event_type_id'.
com.microsoft.sqlserver.jdbc.SQLServerException: The ALTER TABLE statement conflicted with the FOREIGN KEY constraint "$usm_r_r000029af00000000". The conflict occurred in database "mdb", table "dbo.usm_rule_event_type", column 'event_type_id'.
at com.microsoft.sqlserver.jdbc.SQLServerException.makeFromDatabaseError(SQLServerException.java:217)
at com.microsoft.sqlserver.jdbc.SQLServerStatement.getNextResult(SQLServerStatement.java:1635)
at com.microsoft.sqlserver.jdbc.SQLServerPreparedStatement.doExecutePreparedStatement(SQLServerPreparedStatement.java:426)
at com.microsoft.sqlserver.jdbc.SQLServerPreparedStatement$PrepStmtExecCmd.doExecute(SQLServerPreparedStatement.java:372)
at com.microsoft.sqlserver.jdbc.TDSCommand.execute(IOBuffer.java:6276)
at com.microsoft.sqlserver.jdbc.SQLServerConnection.executeCommand(SQLServerConnection.java:1794)
at com.microsoft.sqlserver.jdbc.SQLServerStatement.executeCommand(SQLServerStatement.java:184)
at com.microsoft.sqlserver.jdbc.SQLServerStatement.executeStatement(SQLServerStatement.java:159)
at com.microsoft.sqlserver.jdbc.SQLServerPreparedStatement.executeUpdate(SQLServerPreparedStatement.java:315)
at org.apache.commons.dbcp2.DelegatingPreparedStatement.executeUpdate(DelegatingPreparedStatement.java:98)
at org.apache.commons.dbcp2.DelegatingPreparedStatement.executeUpdate(DelegatingPreparedStatement.java:98)
at com.ca.usm.datasource.DBJDBC.update(DBJDBC.java:1238)
at com.ca.usm.datasource.DBSource.executeUpdate(DBSource.java:1527)
at com.ca.usm.datasource.DBSource.executeUpdate(DBSource.java:1502)
at com.ca.usm.util.seeddata.SeedDataImporter.enableFkAndTriggers(SeedDataImporter.java:351)
at com.ca.usm.util.seeddata.SeedDataIm

Environment

Release : 17.2.0.7

Component : CA SERVICE CATALOG

Resolution

Follow below steps to complete the same

Since you are running the RU07 patch on top of 17.2 GA version here is what we need to go through to force the seeddata entries

1. Login to Catalog Server
2. open the command prompt with Administrator rights
3. change directory to %USM_HOME%
4. Run the usm.cmd command
Note: This will open up the product provided command prompt
5. Runt he below mentioned command with entire paths

Note:

PROGRA~1 = Refers to the "Program File" folder (installed directory)
SERVIC~2 = Refers to "Service Catalog" folder

Command 1: 
seeddata.bat -n "c:\PROGRA~1\ca\SERVIC~2\config.properties" -o "c:\PROGRA~1\ca\SERVIC~2\config.properties" "c:\PROGRA~1\ca\SERVIC~2\catalog\scripts\MDB\SQL"

Command 2: 
seeddata.bat -n "c:\PROGRA~1\ca\SERVIC~2\config.properties" -o "c:\PROGRA~1\ca\SERVIC~2\config.properties" "c:\PROGRA~1\ca\SERVIC~2\view\scripts\MDB\SQL"

Command 3: 
seeddata.bat -n "c:\PROGRA~1\ca\SERVIC~2\config.properties" -o "c:\PROGRA~1\ca\SERVIC~2\config.properties" "c:\PROGRA~1\ca\SERVIC~2\catalog\scripts\MDB_Leh\SQL"

Command 4: 
seeddata.bat -n "c:\PROGRA~1\ca\SERVIC~2\config.properties" -o "c:\PROGRA~1\ca\SERVIC~2\config.properties" "c:\PROGRA~1\ca\SERVIC~2\view\scripts\MDB_Leh\SQL"

Note: Verify the seeddata.log file for any exceptions in this case. If not, we are good with the seeddata commands

Additional Information

Note: This KB Article is specific to RU07 patch seeddata enforcement