UIM installation on Centos8/ Red Hat 8 fails on UIM 8.51, 9.02, 9.2.

book

Article ID: 197860

calendar_today

Updated On:

Products

NIMSOFT PROBES DX Infrastructure Management

Issue/Introduction

We are trying to configure secondary hub on Centos 8 linux platform. Using nimldr 9.2 version and have tried multiple linux installers 'install_LINXU_23_64' ver 9.2 latest.

Installer gets stuck trying to figure out the version of Linux. Output below:

Aug 19 23:24:50:727 nimldr: Starting...

Aug 19 23:24:50:727 nimldr: Log Level 0

Aug 19 23:24:50:728 nimldr: nimSessionNew - _probeCheckin failed - communication error

Aug 19 23:24:50:729 nimldr: nimSessionNew - _probeCheckin failed - communication error

Aug 19 23:24:50:729 nimldr: No Controller:communication error

Aug 19 23:24:50:729 nimldr: Ask: Where should nimldr store temporary files? ==>[/opt/nimsoft/tmp]

Aug 19 23:24:52:177 nimldr: Reply: /opt/nimsoft/tmp

Aug 19 23:24:52:177 nimldr: Beginning Robot installation:

Aug 19 23:24:52:177 nimldr: Ask: Is this a Cloud installation? ==>[no]

Aug 19 23:24:53:725 nimldr: Reply: no

Aug 19 23:24:53:725 nimldr: Ask: Do we have the installation file locally? ==>[no]

Aug 19 23:24:59:718 nimldr: Reply: no

Aug 19 23:24:59:718 nimldr: Ask: Is there a host running a Nimsoft Hub we can query for the installation file? ==>[yes]

Aug 19 23:25:01:134 nimldr: Reply: yes

Aug 19 23:25:01:135 nimldr: nimSessionNew - _probeCheckin failed - communication error

Aug 19 23:25:01:135 nimldr: nimSessionNew - _probeCheckin failed - communication error

Aug 19 23:25:01:135 nimldr: No Controller:communication error

Aug 19 23:25:01:135 nimldr: Ask: What is the IP address of the host running a Nimsoft Hub? ==>[]

Aug 19 23:25:07:919 nimldr: Reply: 10.2.6.93

Aug 19 23:25:08:026 nimldr: Found Controller!

Aug 19 23:25:08:078 nimldr:

Preparing to search for Archives:

Aug 19 23:25:08:078 nimldr: Ask: What is the Nimsoft Domain called (*=search)? ==>[Net]

Aug 19 23:25:08:919 nimldr: Reply: Net

Aug 19 23:25:08:919 nimldr: Ask: What is the Nimsoft Hub called (*=search)? ==>[HubPriHA]

Aug 19 23:25:10:439 nimldr: Reply: HubPriHA

Aug 19 23:25:10:439 nimldr: Ask: What is the installation file called? ==>[install_LINUX]

Aug 19 23:25:16:087 nimldr: Reply: install_LINUX_23_64

Aug 19 23:25:16:087 nimldr:

Searching for Archives:

Aug 19 23:25:16:087 nimldr: We need to log in to NMS to query for available archives

Aug 19 23:25:16:087 nimldr: Attempting to log in to NMS...

Aug 19 23:25:27:003 nimldr: Detected distsrv running on 10.2.6.93/48007

Aug 19 23:25:27:003 nimldr: Looking for install_LINUX_23_64

Aug 19 23:25:27:031 nimldr: Beginning download of install_LINUX_23_64

Aug 19 23:26:17:228 nimldr:

Done!

Aug 19 23:26:17:228 nimldr: AskInt: What are we installing? (1=Robot,2=Infrastructure) ==>[1]

Aug 19 23:26:20:533 nimldr: Reply: 1

Aug 19 23:26:20:533 nimldr: Installing Robot

Aug 19 23:26:20:533 nimldr: Extracting files from archive /opt/nimsoft/tmp//install_LINUX_23_64.zip to temp directory /opt/nimsoft/tmp/

Aug 19 23:26:21:117 nimldr: Ask: Where should NMS be installed? ==>[/opt/nimsoft]

Aug 19 23:26:23:688 nimldr: Reply: /opt/nimsoft

Aug 19 23:26:23:688 nimldr: Install path: /opt/nimsoft/

Aug 19 23:26:23:689 nimldr: Ask: Automatically unregister Robot from Hub on termination? ==>[no]

Aug 19 23:26:25:102 nimldr: Reply: no

Aug 19 23:26:25:102 nimldr: Ask: Should this Robot run in passive mode? ==>[no]

Aug 19 23:26:26:597 nimldr: Reply: no

Aug 19 23:26:26:598 nimldr: Ask: What is this Nimsoft Domain called? ==>[Net]

Aug 19 23:26:29:270 nimldr: Reply: Net

Aug 19 23:26:29:270 nimldr: Ask: Which Nimsoft Hub should this Robot connect to? ==>[HubPriHA]

Aug 19 23:26:30:491 nimldr: Reply: HubPriHA

Aug 19 23:26:30:491 nimldr: Ask: What is that Nimsoft Hub's IP address? ==>[10.2.6.93]

Aug 19 23:26:32:582 nimldr: Reply: 10.2.6.93

Aug 19 23:26:32:583 nimldr: Could not figure out what Linux version you are running!

Aug 19 23:26:32:583 nimldr: Please report the following system information to [email protected]

Aug 19 23:26:32:583 nimldr:   sysname:  Linux

Aug 19 23:26:32:583 nimldr:   node   :  x.net

Aug 19 23:26:32:583 nimldr:   release:  4.18.0-147.8.1.el8_1.x86_64

Aug 19 23:26:32:583 nimldr:   version:  #1 SMP Thu Apr 9 13:49:54 UTC 2020

Aug 19 23:26:32:583 nimldr:   machine:  x86_64

Aug 19 23:26:32:583 nimldr: Could not figure out what operating system you are running!

Aug 19 23:26:32:583 nimldr: Please report the following system information to [email protected]

Aug 19 23:26:32:583 nimldr:   sysname:  Linux

Aug 19 23:26:32:583 nimldr:   node   :  x.net

Aug 19 23:26:32:583 nimldr:   release:  4.18.0-147.8.1.el8_1.x86_64

Aug 19 23:26:32:583 nimldr:   version:  #1 SMP Thu Apr 9 13:49:54 UTC 2020

Aug 19 23:26:32:583 nimldr:   machine:  x86_64

Aug 19 23:26:32:583 nimldr: Could not figure out what Linux version you are running!

Aug 19 23:26:32:583 nimldr: Please report the following system information to [email protected]

Aug 19 23:26:32:583 nimldr:   sysname:  Linux

Aug 19 23:26:32:583 nimldr:   node   :  x.net

"nimldr.log" 

Cause

CentOS 8 support was added with UIM 20.1 and is not officially supported on earlier versions.

Environment

Release : 8.51, 9.02, 9.2.

Component : UIM - ROBOT_RPM

Resolution

You have selected UIM 8.51 as the version of UIM. Please be aware that this version will be end of support on October 31, 2020 and UMP will stop working on January 1, 2021 due to Adobe Flash end of life. UIM 8.51 was end of support last March but due to covid, has been extended until end of October.

You must upgrade to 9.02 as soon as possible to be able to install UIM 20.3 in October if you wish to continue to use UIM.

CentOS 8 and Red Hat 8 are only supported on UIM 20.1. If you need to use CentOS 8 then you will need to upgrade your UIM to 9.02, then to 20.1. There is no way to force this to work in UIM 8.51, you have to upgrade if you want to support CentOS 8.



Here is the link for the upgrade path:


https://techdocs.broadcom.com/content/broadcom/techdocs/us/en/ca-enterprise-software/it-operations-management/unified-infrastructure-management/20-1/installing/product-compatibility/supported-upgrade-paths.html

Here is the robot compatibility matrix showing CentOS 8 was added with robot 9.3:

https://techdocs.broadcom.com/content/broadcom/techdocs/us/en/ca-enterprise-software/it-operations-management/unified-infrastructure-management/20-1/installing/product-compatibility/ca-uim-compatibility-matrix.html#concept.dita_3e0b025267e987b38f84e5c201b1b6f9da447ad5_RobotSupportMatrix