XOG Login Failure in a new install or upgrade HTTP 400
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XOG Login Failure in a new install or upgrade HTTP 400

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Article ID: 197818

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Updated On:

Products

Clarity PPM On Premise Clarity PPM SaaS

Issue/Introduction

XOG Login is failing in a new install or upgrade, but was working previously. In "verbose" logging mode the error is seen:

HTTP Error: Status-Code: 400: null

ca-log shows errors like:

niku.xog (clarity:none:none:none) XOG POST failed
java.lang.NullPointerException
 at com.niku.union.utility.StreamUtils.writeToFile(StreamUtils.java:435)
 at com.niku.union.utility.StreamUtils.writeToFile(StreamUtils.java:391)
 at com.niku.xog.service.XOGSOAPServlet.doPost(XOGSOAPServlet.java:127)

Environment

Release : Any Supported Release

Cause

Due to the Clarity application on the server being unable to write to the temp directory on the server. As a part of the XOG process, files are saved into the temp directory and then processed.

Resolution

  • Ensure the user starting Clarity service has the permissions to the system's temp directory
  • Check that the OS Temp directory exists and is accessible
  • Ensure the Clarity tempdir is correctly set up in properties.xml as per: Clarity needs tempFile to be set in properties.xml
  • If Java tmpdir is set up in properties.xml, the folder should exist and user has to have permissions to it. More information here: Setting Temp directory for Clarity tmpdir in JVM parameters
  • Upon making any changes, make sure you do a complete remove and redeploy of the services