Discovery wizard unable to discover network devices using SNMP v3
search cancel

Discovery wizard unable to discover network devices using SNMP v3

book

Article ID: 197637

calendar_today

Updated On:

Products

DX Unified Infrastructure Management (Nimsoft / UIM) CA Unified Infrastructure Management On-Premise (Nimsoft / UIM) CA Unified Infrastructure Management SaaS (Nimsoft / UIM)

Issue/Introduction

Running Discovery Wizard to discover some network devices (routers) using SNMP V3 but the devices are not getting discovered.

Environment

  • Release: 9.2.0
  • Component: UIM - SNMPCOLLECTOR

Cause

discovery_agent logs at log level 5 showed the following messages:

[DiscoveryRun, discovery_agent] 2 duplicate SNMPv3 EngineIDs
  • Note that some duplicates may be the result of the discovery IP scopes including multiple IP addresses for the same device.
  • This is followed by the EngineID and the ip addresses of the devices that are attempting to use the same engine id.

Resolution

  • For SNMP V3 discovery the EngineID's for devices must be unique in the environment.
  • Duplicate engine id's will result in failure to discover the duplicates using V3.
  • Note: SNMP V2 and V1 will still discover the devices as the EngineID is only used for V3.