Reports are missing data based on time slices in GCP

book

Article ID: 197461

calendar_today

Updated On:

Products

Clarity PPM SaaS

Issue/Introduction

One or more of the following symptoms are reported:

1. Custom and OOTB reports show missing data, not generating results as expected
2. Custom and stock portlets do not return any data, as it previously did.
3. BG logs show one or more of the following errors:

 
ERROR 2020-08-13 06:24:04,690 [Dispatch Time Slicing : [email protected] (tenant=clarity)] niku.njs (clarity:user:xxxx__xxxx:Time Slicing) Error executing job: 5148111 org.postgresql.util.PSQLException: An I/O error occurred while sending to the backend. at org.postgresql.core.v3.QueryExecutorImpl.execute(QueryExecutorImpl.java:336) at org.postgresql.jdbc.PgConnection.executeTransactionCommand(PgConnection.java:754) at org.postgresql.jdbc.PgConnection.rollback(PgConnection.java:797) at jdk.internal.reflect.GeneratedMethodAccessor112.invoke(Unknown Source)

WARN  2020-08-18 19:58:34,785 [Thread-5] persistence.PersistenceController (clarity:......:none) Warning: Attempting to reuse a closed connection. A new connection will be generated.

ERROR 2020-08-13 06:24:03,742 [Dispatch Time Slicing : [email protected] (tenant=clarity)] niku.blobcrack (clarity:admin:….....:Time Slicing) Exception during blobcrack process
org.postgresql.util.PSQLException: This connection has been closed.

Example of report impacted: Missing Time Report, Timesheet Detail

Cause

This is reported as DE57138 and is resolved in 15.8.1.2 (Patch 2).

DE57138: PRJ_BLB_SLICES table data needs to be regenerated




Environment

Release : 15.8.1

Component : CA PPM SAAS APPLICATION

Resolution


Our Infrastructure and Engineering team identified this 2-part issue:
1. The database connection pooling issue is stabilized where it affected the job scheduler, particularly the Time Slicing job, as this job runs frequently and is most affected.
2. There is an identified portion of Time Slicing code that was revised to address the condition above, so that a complete manual reslice is not needed.

If the issue does happen before the release containing the fix is applied, reslice the affected time slice ids in batches with the following instructions.

    1. Go to Administration > Data Administration > Time Slices 
    2. Sort by ID in ascending order
    3. Right-click on each impacted slice id to open the time slice definition in a new browser tab.
    4. Set "Number of Periods" to a different number, i.e 731 (incrementing current number by 1)
    5. Click Save and Return
    6. Do steps 3 to 5 for each slice in question.
    7. Have the next instance of the Time Slicing job process the slice ID that was changed. It will regenerate the data.
    8. Once the Time Slicing job completes, run the full Load DWH job to completion.

Notes:
Refer to the highlighted time slices which are commonly used to populate reports.
It is highly recommended to pause the Time Slicing ahead of any upgrade or maintenance schedule.

Additional Information

1 DAILYRESOURCEAVAILCURVE
2 DAILYRESOURCEACTCURVE
3 DAILYRESOURCEESTCURVE
4 MONTHLYRESOURCEACTCURVE
5 MONTHLYRESOURCEESTCURVE
6 MONTHLYRESOURCEALLOCCURVE
7 MONTHLYRESOURCEAVAILCURVE
10 DAILYRESOURCEALLOCCURVE
11 DAILYRESOURCEBASECURVE
300 WEEKLYRESOURCEBASECURVE
305 MONTHLYBASEASSIGNCOSTS
306 WEEKLYRESOURCEHARDALLOC
307 WEEKLYBASEASSIGNCOSTS
312 MONTHLYRESOURCEBASECURVE
55555 DAILYRESOURCETIMECURVE
55556 WEEKLYRESOURCEACTCURVE
55557 WEEKLYRESOURCEESTCURVE
55558 WEEKLYRESOURCEALLOCCURVE
55559 WEEKLYRESOURCEAVAILCURVE