Tomcat access log import/analyze job errors (Connection refused to host)
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Tomcat access log import/analyze job errors (Connection refused to host)

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Article ID: 197421

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Updated On:

Products

Clarity PPM On Premise Clarity PPM SaaS

Issue/Introduction

The Tomcat access log import/analyze job completes successfully, but on the log files there are some errors recorded.

Job executed and error reproduced, log shows:

Tower instance acquired
Discovering services via multicast.... 30 seconds
Discovered 7 addresses

Exiting abnormally with error: Connection refused to host: XX.X.XXX.XXX; nested exception is:
java.net.ConnectException: Connection refused

Cause

This is caused by an issue in multicasting or JDBC Ping between the different nodes of the server.

Resolution

Check with the network team to see if there was any issue with the server with this IP, then once fixed or confirmed there is no issue: 

  1. Stop the services
  2. If on JDBC Ping, truncate CMN_JGROUPS_PING table
  3. Start the services back up