Intellisig error "The integrity checker generated an error during initialization. The certificate may not be installed on agent."
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Intellisig error "The integrity checker generated an error during initialization. The certificate may not be installed on agent."

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Article ID: 19734

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Updated On:

Products

CA Automation Suite for Data Centers - Configuration Automation CA Client Automation - Asset Management CA Client Automation - IT Client Manager CA Client Automation CA Client Automation - Remote Control CA Client Automation - Asset Intelligence CA Client Automation - Desktop Migration Manager CA Client Automation - Patch Manager

Issue/Introduction

The Software Inventory Collect task is in status ERROR with message like:

"Intellisig named Java SE Runtime Environment, version 1.3, UUID 6A3140EC-D329-4BB7-80CE-8A35744B96EC, script file JRE.dms. The integrity checker generated an error during initialization. The certificate may not be installed on agent."

In TRC_UAM_CAEVMSCLI*.log (Unix/Linux) or TRC_UAM_AMSWSIGSCAN_*.log (Windows) following errors appear :

ERROR | CCertStore::RetrieveCertificate: cert not found
ERROR | IntellisigCert::init: Failed to LoadPeerPublicIdentity

and

DETAIL | CiSig::verifyIntegrity : starts
ERROR | Intellisig Integrity Checker failed to initalise

Environment

Client Automation (ITCM) -- any version

Cause

The certificate "Manager Signer" used for intellisig signature is not present in certdb and should be imported.

Execute this command: cacertutil list
If certificate "Manager Signer" does not appear under "Listing identity certificates" and Listing tags
 
Listing identity certificates:
Subject : CN=manager signer,O=computer associates,C=us 
Listing tags:
ManagerSigner = CN=manager signer,O=computer associates,C=us

Resolution

Unix/Linux:
# . /etc/profile.CA all
# cd /opt/CA/DSM/caf/bin
# cacertutil import -i:itrm_dsm_mngrsgn.cer -it:x509v3 -t:ManagerSigner

and execute this command too for ITCM version >= 14.0 SP1 :
# cacertutil import -i:itrm_dsm_mngrsgn_sha2.cer -it:x509v3 -t:ManagerSigner


On Windows:
Open a Support Case and ask for T6FP011.

# cd C:\Program Files\CA\DSM\Bin
# cacertutil import -i:itrm_dsm_mngrsgn.cer -it:x509v3 -t:ManagerSigner

and execute this command too for ITCM version >= 14.0 SP1 :
# cacertutil import -i:itrm_dsm_mngrsgn_sha2.cer -it:x509v3 -t:ManagerSigner