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Report fails with error "File too large" in Clarity

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Article ID: 197242

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Updated On:

Products

Clarity PPM SaaS Clarity PPM On Premise

Issue/Introduction

Jaspersoft scheduled/immediate reports are failing with the below error:

Caused by: java.lang.reflect.InvocationTargetException
                at sun.reflect.GeneratedMethodAccessor971.invoke(Unknown Source)
                at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
                at java.lang.reflect.Method.invoke(Method.java:498)
                at com.jaspersoft.jasperserver.multipleTenancy.ThreadMultiTenancyRepositoryDecorator$ThreadContextHandler.invoke(ThreadMultiTenancyRepositoryDecorator.java:44)
                ... 65 more
Caused by: com.jaspersoft.jasperserver.api.JSExceptionWrapper: File too large

Caused by: java.io.IOException: File too large

Cause

This problem happens when the Temp folder of the Jaspersoft app is not cleaned and Jaspersoft is unable to write anything further into the Temp Directory. The path of the Temp directory is JASPERSOFT_HOME\Temp

Environment

Release : Any

Resolution

On Premise customers

  1. Stop the Jaspersoft Service 
  2. Delete the contents of the TEMP directory 
  3. Restart the Jaspersoft Services 

GCP Customers

If you are SaaS Customer, log a ticket with Broadcom support for assistance