Clarity: Jaspersoft Report Fails with error " File too large"

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Article ID: 197242

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Updated On:

Products

Clarity PPM SaaS Clarity PPM On Premise

Issue/Introduction

The scheduled/immediate reports starts to fail with below error 

 

Caused by: java.lang.reflect.InvocationTargetException
                at sun.reflect.GeneratedMethodAccessor971.invoke(Unknown Source)
                at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
                at java.lang.reflect.Method.invoke(Method.java:498)
                at com.jaspersoft.jasperserver.multipleTenancy.ThreadMultiTenancyRepositoryDecorator$ThreadContextHandler.invoke(ThreadMultiTenancyRepositoryDecorator.java:44)
                ... 65 more
Caused by: com.jaspersoft.jasperserver.api.JSExceptionWrapper: File too large

Caused by: java.io.IOException: File too large

Cause

This problem happens when the Temp Folder of Jaspersoft App is not cleaned and Jaspersoft is unable to write any further into the Temp Directory. The path of the Temp directory is JASPERSOFT_HOME\Temp

Environment

Release : 15.7.1

Component : CA PPM SAAS JASPERSOFT

Resolution

  • Stop the Jaspersoft Service 
  • Delete the contents of the TEMP directory 
  • Restart the Jaspersoft Services 

Additional Information

Note: If you are SaaS Customer please log a ticket with us and we will help to get this fixed