AE r12 install error - [CAUAJM_E_115001] The specified installation path is already in use
search cancel

AE r12 install error - [CAUAJM_E_115001] The specified installation path is already in use

book

Article ID: 197232

calendar_today

Updated On:

Products

CA Workload Automation AE - Scheduler (AutoSys)

Issue/Introduction

NOTE: This article only applies to the specific scenario in which an AutoSys instance was upgraded from 11.3.6 SP8 to r12.0 and was subsequently backed out by restoring the 11.3.6 SP8 AutoSys directories and 11.3.6.8 database manually.

When trying to run the upgrade a second time, the upgrade throws this message during the Installation Path section:

===========
Installation Path
-----------------
Specify the installation path.

Installation path (Default: /opt/CA/WorkloadAutomationAE):
===============================================================================
Installation Path Validation
----------------------------
Error:
[CAUAJM_E_115001] The specified installation path is already in use:
"/opt/CA/WorkloadAutomationAE". Specify a different path.

PRESS <ENTER> TO ACCEPT THE FOLLOWING (OK):

Environment

Upgrade from 11.3.6 SP8 to 12.0

Cause

Taking backup of just $CASHCOMP and /opt/CA/WorkloadAutomationAE is not enough.  The r12 installer determines the components installed on Linux using the rpm database.  During the first upgrade from 11.3.6 SP8 to r12.0, the rpm data related to the AutoSys 11.3.6 SP8 is wiped off. This is what causes this issue.

The output of the 'lsm -l -O rpm|grep ca-waae' command on a machine where the SP8 is currently running and valid will give the output below (GOOD INSTANCE):

[root@test-server ~]# lsm -l -O rpm|grep ca-waae
RPM      ca-waae-agent-helper           11.3.6               linux
RPM      ca-waae-asapi                  11.3.6               linux
RPM      ca-waae-client                 11.3.6               linux
RPM      ca-waae-common                 11.3.6               linux
RPM      ca-waae-scheduler              11.3.6               linux
RPM      ca-waae-db                     11.3.6               linux
RPM      ca-waae-common-cs2             11.3.6               linux
RPM      ca-waae-common-cs              11.3.6               linux
RPM      ca-waae-server                 11.3.6               linux
RPM      ca-waae-common-sac             11.3.6               linux
RPM      ca-waae-base                   11.3.6               linux

When you install the r12 and revert to an old backup of AutoSys and shared components, you will get no output (BAD INSTANCE):

[root@test-server ~]# lsm -l -O rpm|grep ca-waae
[root@test-server ~]# 

Resolution

Procedure to fix this:

1. Mount the CA WAAE r11.3.6 SP8 DVD

[root@test-server Linux]# cd /share1/UAJM/11.3.6/SP8/waae1136_unix

[root@test-server waae1136_unix]# ls -l
acknowledgements.txt  

Documentation  

Linux  

VendorEULA.txt  

version_check.sh  

wa_setup.sh

2. Change dir to Linux/WorkloadAutomationAE/RPM/ in the DVD location

[root@test-server waae1136_unix]# cd Linux/WorkloadAutomationAE/RPM/

[root@test-server RPM]# ls -l
ca-waae-agent-helper-11.3.6-1643.i386.rpm  
ca-waae-common-11.3.6-1643.i386.rpm      
ca-waae-db-11.3.6-1643.i386.rpm
ca-waae-asapi-11.3.6-1643.i386.rpm         
ca-waae-common-cs-11.3.6-1643.i386.rpm   
ca-waae-scheduler-11.3.6-1643.i386.rpm
ca-waae-base-11.3.6-1643.i386.rpm          
ca-waae-common-cs2-11.3.6-1643.i386.rpm  
ca-waae-sdk-11.3.6-1643.i386.rpm
ca-waae-client-11.3.6-1643.i386.rpm        
ca-waae-common-sac-11.3.6-1643.i386.rpm  
ca-waae-server-11.3.6-1643.i386.rpm

3. Run below commands in the same order:

rpm -Uvh --justdb ca-waae-base-11.3.6-1643.i386.rpm
rpm -Uvh --justdb ca-waae-common-11.3.6-1643.i386.rpm
rpm -Uvh --justdb ca-waae-agent-helper-11.3.6-1643.i386.rpm
rpm -Uvh --justdb ca-waae-asapi-11.3.6-1643.i386.rpm
rpm -Uvh --justdb ca-waae-common-cs2-11.3.6-1643.i386.rpm
rpm -Uvh --justdb ca-waae-common-sac-11.3.6-1643.i386.rpm
rpm -Uvh --justdb ca-waae-common-cs-11.3.6-1643.i386.rpm
rpm -Uvh --justdb ca-waae-client-11.3.6-1643.i386.rpm
rpm -Uvh --justdb ca-waae-db-11.3.6-1643.i386.rpm
rpm -Uvh --justdb ca-waae-server-11.3.6-1643.i386.rpm
rpm -Uvh --justdb ca-waae-scheduler-11.3.6-1643.i386.rpm


You can now run the r12.0 upgrade and it will allow you to upgrade the instance with no further issue.