Spectrum NCM configuration task did not complete

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Article ID: 197139

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Updated On:

Products

CA Spectrum

Issue/Introduction

The alarm is NCM configuration task did not complete.


Cause

  • The NCM task is taking longer to process all devices than is allotted within the scheduled window.

Environment

Release : 10.4.1

Component : Spectrum Core / SpectroSERVER

Resolution

First, try to increase the window for the task and see if this allows it to complete.

The following settings will also speed up task device processing:

  • Increase the Task Work Queue Size from 10 (Default) to 15.   This will increase the number of concurrent devices that are processed at the same time.

This setting should be used judiciously as setting this value too aggressively can introduce performance issues on the Spectrum Server.

  • Disable Device Retries (Many device login failures can greatly slow down the device processing as the default retry value is 3):

1.  Navigate to SPECROOT/NCM/config.xml

2.  Add the following parameter:

3.  Kill\End Task the ncmservice.exe process to enable the new setting (processd will automatically re-spawn a new ncmservice process)

 

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