Portlet System error to one user only (Corrupt filter)
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Portlet System error to one user only (Corrupt filter)

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Article ID: 197073

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Updated On:

Products

Clarity PPM On Premise

Issue/Introduction

One of your portlets does not work for one user only. You get "ERROR" and nothing else. Restoring defaults does not work

Environment

Release : All Supported Clarity releases

Component : CLARITY STUDIO

Cause

The issue is caused by a corrupt filter on this portlet which is why restoring defaults does not work.

Resolution

  1. Looking in the SQL trace, find the filter expression ids run for the exact same portlet with Support's help.
    Example queries to look for:

    SELECT  a.*

          FROM     cmn_attribute_value_sets a
          WHERE    a.view_code = 5026088
          AND      a.user_id = 5289155  order by a.name

        SELECT * FROM odf_filter_expressions
          WHERE object_code = 5333564
          AND object_instance_id = 5753877

     2. Once you identified the correct filter, run the query to fix the issue:

update odf_filter_expressions
    set expression ='1==1'
    where id =5000000

commit

     3. Flush the caches before testing again

Additional Information

See also: Restore Defaults to resolve corruption or errors