Schedule Time for Job not Showing Correctly

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Article ID: 196882

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Updated On:

Products

Clarity PPM SaaS Clarity PPM On Premise

Issue/Introduction

On the Scheduled Job list view in Clarity, the Scheduled time for job is showing  as Saturday '8/9/20 12:15 AM', but in the job properties it is showing a Start Date of Friday '8/8/2020' and a Start Time of 12AM :15Min. 

When is the job scheduled to really run and why do different dates show?

Cause

This issue occurs if the users time zone and the server time zone are different and the time conversion goes through midnight. In this example, the user's time zone is Eastern, while the server time zone is Pacific. 

Environment

Release : 15.6.1

Component : CA PPM SAAS APPLICATION

Resolution

The time in the database is getting adjusted the 3 hours to account for the difference in time zone. so the run time is 9:15PM Pacific. However, the day does not correctly adjust to the day before (Friday) and instead remains at Saturday. So the job really ends up being scheduled to run on Saturday at 9:15PM Pacific.