Tasks remaining "in progress"

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Article ID: 196799

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Updated On:

Products

CA Identity Manager CA Identity Governance CA Identity Portal CA Identity Suite

Issue/Introduction

CA Identity Manager (IAM) Provisiong tasks are stuck "in progress".  There are no significant errors logged.

 

Server Log

14:12:02,945 ERROR [com.netegrity.ims.exception.EventExecuteStateException] (Thread-15 (HornetQ-client-global-threads-325109474)) Exception: : [facility=4 severity=3 reason=0 status=6 message=Unrecognized command]
No items found
 at com.netegrity.llsdk6.imsimpl.securityengine.PolicyEngine.synchIdentityPolicies(PolicyEngine.java:1860) [imsapi6.jar:]
 at com.netegrity.llsdk6.imsimpl.provider.SynchronizationProviderImpl.synchronizeUserWithIdentityPolicies(SynchronizationProviderImpl.java:61) [imsapi6.jar:]
 at com.netegrity.ims.events.SynchronizeUserEvent.execute(SynchronizeUserEvent.java:114) [ims.jar:]

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Debug Entries

14:56:48,914 DEBUG [ims.llsdk.typeregistry] (Thread-9 (HornetQ-client-global-threads-991627022)) Did not find definition for type USER

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Cause

Further investigation identified a provisioning role had been deleted and this had not been updated in a Policy Xpress (PX) policy.  The Policy was looping checking the membership from the missing Provisiong Role.

Environment

Release : 14.3

Component : IdentityMinder(Identity Manager)

Resolution

The workaround to this issue is to amend the Policy Xpress (PX) policy to accurately reflect the Provisioning Roles in use.